I know that everyone is experiencing their own struggles during these interesting times, but perhaps I can nevertheless entertain you with mine. My struggle wasn’t grand and had nothing to do with hunger or disease, but it was frustrating.

On Wednesday morning I could not start up the 2003 G4 Macintosh that powers my studio. At first I considered my plan B, which was to move the ProTools HD PCI cards from the computer to a Magma box I bought about ten years ago. At that time I thought how grand it would be to connect the ProTools cards inside the Magma either to the G4 or to my laptop, so I could edit or record somewhere beside my studio. It turned out that while my laptop could easily connect to the ProTools HD cards in the Magma, the G4 was crashing too often when connected this way. So I moved the cards back into the G4 and the Magma box was languishing in the back of the studio.

I opened up the G4 and the Magma box and moved the cards. In order to connect the Magma to the newish laptop I had to use not one, but two adaptors. One connected the old laptop PCI standard to a newer, and slimmer, laptop version, and the second one adapted that to a female Thunderbolt2 connector.

I downloaded ProTools Free and discovered that it wasn’t compatible with the macOS version that was installed on the laptop. I downloaded the software to an older laptop and was able to start it up. After an hour of configuring the software I connected the Magma box… but neither the laptop nor the ProTools software could see the connected hardware. Oh well, perhaps the signal was lost somewhere in the adapters.

I realized that in order to continue working on the new album I had to get the G4 going. I opened the computer and moved the cards back into it. The computer started up. I shut it down, moved it into the enclosure in the back of the studio, and it started up again. When I plugged in the USB cable that connects to the USB extension the G4 shut itself down immediately. I plugged in a different cable and the computer started up. I went to the house to have a bite to eat. When I returned the computer would again not start up. Power button? Power supply? I put a new battery into the G4 – computers have a battery that, among other things, keeps the internal clock going. I reset the PRAM. I ordered an old iMac keyboard I found on the internet, an odd keyboard that has a power button on the keyboard itself that said to override the power button on the front of the machine.


On Friday afternoon I was able to start up the computer and work for a couple of hours. The computer worked perfectly and gave no indication of anything being amiss. Saturday morning it would not start up. The keyboard with the magical power button arrived that morning and I connected the keyboard… nothing. I gave up and played guitar for an hour. It’s now Sunday morning and the mystery persists. Is it a loose wire somewhere? Is it just a temperamental old computer?